cocoapods not installed or not in valid state. flutter

cocoapods not installed or not in valid state. flutter

This problem might be because you have multiple versions of cocoapods installed.

 

This problem might be because you have multiple versions of cocoapods installed.

You can check and resolve it running:

  • gem list check to see if multiple versions of cocoapod are installed
  • sudo gem uninstall cocoapods it will prompt you to select which one to uninstall, or if you want to uninstall all
  • sudo gem install cocoapods

Additional step if you uninstalled all cocoapods

  • Change to the iOS directory of your Flutter project
  • pod install

That should then allow you to run an xcode build to an iOS device.

https://tinyurl.com/hostinger-host

 
cocoapods not installed or not in valid state. flutter

Add a Comment

Your email address will not be published.